mach-nix/tests/test_remove_unwanted_deps.nix
DavHau 309b7d5f1a disable some eval tests for conda
Most of these got stuck because of a resolution too deep error.
2022-02-14 12:42:38 +07:00

18 lines
451 B
Nix

{
baseArgsMkPython ? {},
baseArgsBuildPythonPackage ? {},
mach-nix ? import ../. {},
...
}:
with builtins;
# if removing dependency doesn't work this build would raise:
# Could not find a version that satisfies the requirement packaging (from sphinx)
mach-nix.mkPython (baseArgsMkPython // {
python = "python39";
requirements = ''
librosa==0.8.0
'';
providers.soundfile = "sdist";
providers._default = "wheel,sdist,nixpkgs";
})