mach-nix/tests/test_flakes_legacy_consistent.nix
DavHau 309b7d5f1a disable some eval tests for conda
Most of these got stuck because of a resolution too deep error.
2022-02-14 12:42:38 +07:00

24 lines
570 B
Nix

{
baseArgsMkPython ? {},
baseArgsBuildPythonPackage ? {},
mach-nix ? import ../. {},
system ? builtins.currentSystem or "x86_64-linux",
...
}:
with builtins;
let
mkPythonFlakes = (getFlake (toString ../.)).lib.${system}.mkPython;
pyFlakes = mkPythonFlakes {
requirements = "requests";
providers._default = "wheel,sdist,nixpkgs";
};
py = mach-nix.mkPython (baseArgsMkPython // {
requirements = "requests";
providers._default = "wheel,sdist,nixpkgs";
});
in
if pyFlakes == py then
py
else
throw "flakes and legacy output differ"